CoolTerm - data in txt file are not in the rows

If you have specific questions or problems with any of my Open Source Projects, post them here.
Post Reply
Karcsi763
Posts: 2
Joined: Fri Sep 09, 2022 12:53 pm

CoolTerm - data in txt file are not in the rows

Post by Karcsi763 »

Hi,
I have tested the CoolTerm software just now first time. Very cool software. The received data are received and shows in the CoolTerm in the rows. New string are put in to new row. That works. But if I start the data logging in to txt file (recording), the data in the txt file are all in one row (not multiple rows).

CoolTerm window:
21:05:15, 5, 6
21:05:30, 9, 5
21:05:45, 7, 5

Text file:
21:05:15, 5, 621:05:30, 9, 521:05:45, 7, 5

What I need to change in the settings to have all data strings in txt file in the multiple rows? New data new row. The data string in serial link is terminated by character 0x0A.

I have tried in "Connection Options", tab "Receive" set the tick for "Wait for termination string" and modified default string from 0D 0A to 0A, but it does not make any difference.

The only option works is "Option B", to manually highlight the all data CTRL+V and CTRL+V in to empty text file. Then the data are in rows. But this way is a bit impractical when I will read whole 4Mbit EEPROM memory.

Thank you for help with this issue.
Last edited by Karcsi763 on Fri Sep 09, 2022 6:10 pm, edited 3 times in total.
User avatar
roger
Site Admin
Posts: 350
Joined: Fri Apr 24, 2009 12:41 am
Contact:

Re: CoolTerm - data in txt file are not in the rows

Post by roger »

Hi,

I assume you are doing this on a Windows system?

When capturing data to file, it is recorded exactly as it is received, and when the file is later opened with a text editor, it will display the file to the best of its abilities. The default line ending for windows is CR+LF. Your receive data is terminated with on LF (default on UNIX systems), which some text editor can't properly display.
I would recommend Notepad++ (https://notepad-plus-plus.org) or similar to view recorded data with only LF terminations.

CoolTerm converts all received line endings for display purposes to the default for the current system, i.e. the data you're copying from the main window is terminated with CR+LF, even though only LFs were received.

If not specifically needed, waiting for termination string is not strictly necessary unless you have a specific reason (i.e. your time stamping the received data). Also, if you do enable this feature, you should also turn on "retain termination string".

I hope this helps.

Roger
Karcsi763
Posts: 2
Joined: Fri Sep 09, 2022 12:53 pm

Re: CoolTerm - data in txt file are not in the rows

Post by Karcsi763 »

Hi Roger,

Yes, Windows.

You are No.1. It works. (thumb up)

I have forgotten to mention in post above, that I can change the LF (0x0A) to any character, so no need to use Notepad++. I was confused, that CoolTerm converted my line ending to default line ending, so it showed properly.
You have explained me very clear, why text file does not make proper line ending. There was missing CR for standard windows Notepad.
I have added in to my program (PIC micro-controller) CR, now at the end of the string is 0x0D following by 0x0A and it works well.

Thank you so much.

Have a good day.
User avatar
roger
Site Admin
Posts: 350
Joined: Fri Apr 24, 2009 12:41 am
Contact:

Re: CoolTerm - data in txt file are not in the rows

Post by roger »

Great! Glad I was able to help.

Roger
Post Reply