Page 1 of 1

CoolTerm on Raspberry Pi

Posted: Sun Jan 01, 2023 6:20 am
by TomB4321
Hello Forum

I have been using CoolTerm on a windows laptop for a while to communicate/test serial data for a variety of sensors (GPS, motion, pressure sensors and more....I'm a Hydrographic surveyor)

My christmas present to myself was a Raspberry Pi and a 5" display, from which i intend to create a more portable/pocket friendly serial reader and web interface tool.

When I load the Raspberry Pi version of Coolterm the windows/menus/dialog boxes are too large, I can neither scroll down or resize to fit the!

Re: CoolTerm on Raspberry Pi

Posted: Thu Jan 05, 2023 1:38 pm
by roger

how tall is your display? The CoolTerm main window can be resized for small displays (down to 250 pixels wide and 150 pixels tall, and you can even turn off the toolbar for more display real estate), but unfortunately, the settings dialogs can't be resized. The connection settings window is 540 pixels tall, and the preferences window is about 560 pixels tall. However, if your 5" screen is not tall enough, there is an easy way to move these windows around to access all their GUI elements. Simply press and hold the ALT key and then click the window anywhere to drag it around. This should let you drag everything into view. ... dow-around

I hope this helps.


EDIT: I just found a bug that prevents the width of terminal window to be made less than 800 pixels on Linux platforms. I will fix that for the next release.

Re: CoolTerm on Raspberry Pi

Posted: Thu Jan 05, 2023 3:25 pm
by TomB4321
Hi Roger,

Many thanks for the reply and information.

My screen 800X480, so the Terminal window fits width wise okay. It is the bottom of the Connection Options/Preferences window that I can't access. Luckily at the moment I can select com ports/baud rate and then just press enter or use the connection options in the bottom left corner.

I tried holding the Alt key, but it doesn't move the Option type windows unfortunately!

Re: CoolTerm on Raspberry Pi

Posted: Thu Jan 05, 2023 5:20 pm
by roger
Hmm, that's weird. I just tried it on my Pi4 set to 848x400 pixels:

Make sure to press end hold the mouse button after holding ALT while dragging.