Page 1 of 1

CoolTerm to ELM327 via bluetooth - receiving not working

PostPosted: Sun Jun 04, 2017 6:55 pm
by kuligram
Hello,
I have a strange situation and I hope somebody could comment. All connections here use bluetooth:
1)Android+"serial bluetooth terminal" app connects to a macbook osx Sierra running CoolTerm - no problems. Coolterm uses "bluetooth-incoming-port"
2)Android+"serial bluetooth terminal" app connects to an OBD II device (ELM327 clone) - no problems
3)Coolterm on the macbook connects to the OBD device, can send commands and I see the OBD receives them and executes, but I was not able to receive anything at all back to CoolTerm running on mac. Using the "OBDII-SPP" port. I guess it's macbook os problem, I wonder if anybody solved this.
Note, that 1 and 2 works, and 1 and 3 uses the same settings in CoolTerm.
Thanks!

Re: CoolTerm to ELM327 via bluetooth - receiving not working

PostPosted: Sat Jul 08, 2017 6:56 pm
by roger
This might be driver issue. To confirm, you can use a different terminal program on the Mac to connect to the ELM327. There are several free alternatives, such as the following:

- http://www.dalverson.com/zterm/
- http://www.furrysoft.de/?page=goserial
- http://www.w7ay.net/site/Applications/S ... index.html

If it is indeed a driver issue, then the above apps should exhibit the same problem. If, on the other hand, the above apps work and CoolTerm doesn't, then that would point to CoolTerm as the culprit and something I would need to look into.